Unable to login

  • 1
  • Question
  • Updated 3 years ago
Unable to login using SAML URL after renaming user name in Active Directory

(Originally posted by joshlpd)
Photo of Archived Post

Archived Post, Official Rep

  • 2132 Posts
  • 5 Reply Likes

Posted 3 years ago

  • 1
Photo of Archived Post

Archived Post, Official Rep

  • 2132 Posts
  • 5 Reply Likes
Hi,

On the domain member computer the Replicon application calls the LsaLookupSids function to translate a security identifier(SID) to a username and the username has been changed on the domain controller. In this scenario the LsaLookupSids returns the old username instead of the new username because of which the log in fails.   To resolve this issue, disable the local SID cache on the domain member computer. To do this, follow these steps:
  • Open Registry Editor.
 # To do this in Windows XP or in Windows Server 2003, click Start, click Run, type regedit, and then click OK.
 # To do this in Windows Vista and newer, Click Start, type regedit in the Start Search box, and then press ENTER.

  • Locate and then right-click the following registry subkey: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa
  • Point to New, and then click DWORD Value. 
  • Type LsaLookupCacheMaxSize, and then press ENTER.
  • Right-click LsaLookupCacheMaxSize, and then click Modify.
  • In the Value data box, type 0, and then click OK.
  • Exit Registry Editor.
  Note:  For more information, please visit Microsoft Support and refer to KB article number: 946358.

(Originally posted by Lingaraj Dharwad)