Submitting empty timesheets accidentally is too easy.

  • 1
  • Problem
  • Updated 2 years ago
  • Solved
The "Add Time Row" button in the header row of the Timesheet page is too close to the Submit button, and the Submit button doesn't attempt to confirm the user's intent before submitting the timesheet. As a result I frequently find myself submitting empty timesheets by mistake, and having to fill out a reason to request unsubmission.

If Gmail can ask if I'm sure that I want to send an email without a subject line, Replicon should be smart enough to ask, "Are you sure?" when I try to submit a timesheet with zero hours.
Photo of Cameron, Andrew

Cameron, Andrew

  • 7 Posts
  • 1 Reply Like
  • frustrated

Posted 2 years ago

  • 1
Photo of Aashnee Kamboj

Aashnee Kamboj, Community Moderator

  • 1602 Posts
  • 109 Reply Likes
Hi Andrew,

Thank you for using the Replicon Community!

We do have this option on our Custom Timesheets. You can setup a validation rule for the same. May I request you to please help me with the timesheet format that your organisation uses?

Thanks,
Aashnee
Photo of Cameron, Andrew

Cameron, Andrew

  • 7 Posts
  • 1 Reply Like
Hi Aashnee! Thanks for your response. :)

I checked our organization's Timesheet Validation Rules, and we have one Enabled which verifies that the weekly total is greater than or equal to a certain amount, but I can still submit empty timesheets even with this rule enabled. As soon as I click Submit, the timesheet is immediately submitted without any sort of validation and I have to enter a reason if I want to Unsubmit it.

Does that help at all? I worry I've left your question about timesheet formats unanswered, but I'm not sure how to find out the answer.

Cheers,
Andrew
Photo of Aashnee Kamboj

Aashnee Kamboj, Community Moderator

  • 1602 Posts
  • 109 Reply Likes
Hi Andrew,

Please follow the below steps to find the timesheet template format:

Go to Administration
Click on Users
Open the user profile and go to timesheet section
find the timesheet template assigned to the user
Go back to Administration 
Click on Timesheet Template
Click on the timesheet template assigned to the user
Confirm the format
Photo of Aashnee Kamboj

Aashnee Kamboj, Community Moderator

  • 1602 Posts
  • 109 Reply Likes
Hi Andrew,

I would also like to have a quick call with you in order to look through the issue further

Thanks,
Aashnee
Photo of Cameron, Andrew

Cameron, Andrew

  • 7 Posts
  • 1 Reply Like
Hi Aashnee, thanks again. The timesheet format we're using is Standard Timesheet. I couldn't find any options on the settings page for the Standard Timesheet template to enable or disable validation rules. On the Administration page, the link to Timesheet Validation Rules says we have one rule enabled checking that the week is greater than or equal to a certain number of hours, but this appears not to apply during the Submission step of a timesheet.

I'm available today before 16:00 EDT or tomorrow betwen 13:00–16:00 EDT.
Photo of Aashnee Kamboj

Aashnee Kamboj, Community Moderator

  • 1602 Posts
  • 109 Reply Likes
Hi Andrew,

In order to apply the rule to the timesheet, please have the rule assigned to the user in the user profile. Go to Administration and click on users. Open the user profile and move to timesheet section. You will see an option to add validation rule here

Aashnee
Photo of Cameron, Andrew

Cameron, Andrew

  • 7 Posts
  • 1 Reply Like
Thank you so much for your help and patience! I'm now observing the expected behaviour. :) I really appreciate your taking the time to help me out with this.