Timesheet & Allocation Viewing Permissions?

  • 1
  • Question
  • Updated 2 years ago
  • Answered
Recently we've had several supervisors and employees ask if there is a way for them to view timesheets and allocations for resources that do not report to them.

Instance 1 - A supervisor was on vacation and asked another supervisor to check her resource timesheets in her absence. Because the covering supervisor was not set up as an approver for these resources, she was not able to do this. Is there a way to set up a permission in Replicon that would allow supervisors to view resource timesheets without making them an approver?

Instance 2 - We would like some of our employees to be able to look up resource allocations but we don't want them to have the ability to make any changes. Is that possible?

Thanks for your help!
Photo of Barens, Kelly

Barens, Kelly

  • 67 Posts
  • 9 Reply Likes

Posted 2 years ago

  • 1
Photo of Nuno Ferreira

Nuno Ferreira, Champion

  • 193 Posts
  • 52 Reply Likes
Hi!

For #2: 
Create a permission set of type "Resource Manager" just with the permission "all resources / view". Then, assign that permission to the "Resource Manager" permission slot in the user configuration.

Hope it helps.
Nuno
Photo of Barens, Kelly

Barens, Kelly

  • 67 Posts
  • 9 Reply Likes
Thanks! I think this worked!
Photo of John C Findley

John C Findley

  • 76 Posts
  • 21 Reply Likes
In Gen 3,
Instance 1 - The vacationing supervisor may / should be able to setup a Substitute User for the period of time on away.

Instance 2 - Depending on what level of access you wish to give, you may be able to setup a View only Permission. I have set a similar permission up for our HR staff to review PTO only.
Photo of Barens, Kelly

Barens, Kelly

  • 67 Posts
  • 9 Reply Likes
What do you mean by a substitute user?
Photo of John C Findley

John C Findley

  • 76 Posts
  • 21 Reply Likes

I may have misunderstood. If not, select the 'Gear' icon toward the upper right and select Settings.

Under Substitute Users, an individual may be added.

This give said individual and additional login as the substitute for the vacationing supervisor.

Photo of Aashnee Kamboj

Aashnee Kamboj, Community Moderator

  • 1592 Posts
  • 109 Reply Likes
Thank you John and Nuno.

Kelly,

You can read about Substitute user here -https://www.replicon.com/help/assigning-a-substitute-user

Thanks,
Aashnee
Photo of Barens, Kelly

Barens, Kelly

  • 67 Posts
  • 9 Reply Likes
That sounds like what we're looking for. However, when I go to the Settings page, there is no button to add a Substitute User. Is this a function we have to enable somewhere else?
Photo of John C Findley

John C Findley

  • 76 Posts
  • 21 Reply Likes

From Aashnee's document provided earlier.

Why can't I see the Substitute Users section?

To set up a substitute for yourself, you must have permission to assign substitutes. If you are an administrator logging in as another user, that user must have permission to assign substitutes; your own permissions will not apply in this case.

Photo of Aashnee Kamboj

Aashnee Kamboj, Community Moderator

  • 1592 Posts
  • 109 Reply Likes
Kelly,

Please check the basic user permission assigned  to the user. Ensure that the permission has "Assign Substitute User" checked:



Thanks,
Aashnee
Photo of Barens, Kelly

Barens, Kelly

  • 67 Posts
  • 9 Reply Likes
Let me clarify. Where do I go to enable this? I see your screenshot above and I read the info in the link provided, but I haven't been able to find the page that it's located on. I've looked under specific users, under Administration. I don't see it anywhere.
Photo of John C Findley

John C Findley

  • 76 Posts
  • 21 Reply Likes
Photo of Barens, Kelly

Barens, Kelly

  • 67 Posts
  • 9 Reply Likes
Ahh I see now. Thank you both very much!
Photo of Barens, Kelly

Barens, Kelly

  • 67 Posts
  • 9 Reply Likes
So we have three User permission sets, I went ahead and checked the Assign Substitute User to all of them. When I checked several employee accounts, there is still not a button to add a substitute. I verified that each employee had one of the three User permissions. Not sure why it isn't working.
Photo of Barens, Kelly

Barens, Kelly

  • 67 Posts
  • 9 Reply Likes
I also just tried creating a new test User permission and checked the box. Still not working.
Photo of John C Findley

John C Findley

  • 76 Posts
  • 21 Reply Likes

Confirm the updated permission was saved.

May want to also try logging out and logging back in.

Photo of Barens, Kelly

Barens, Kelly

  • 67 Posts
  • 9 Reply Likes
Closing the browser completely seemed to do the trick. Good to go. Thanks again! :)