Time Off Module Issues this morning?

  • 1
  • Problem
  • Updated 3 years ago
  • Acknowledged

Is Replicon having Time Off Module Issue this morning?  We cannot load the pop-out window when booking a Time Off.  Calendar will not load.  iPhone and Android app get an error also.

Anyone else having issues?

Photo of Network Administrator

Network Administrator

  • 89 Posts
  • 16 Reply Likes

Posted 3 years ago

  • 1
Photo of Aashnee Kamboj

Aashnee Kamboj, Community Moderator

  • 1558 Posts
  • 108 Reply Likes
Hi,

Thank you for bringing this up. We will quickly investigate and get back to you.

Thanks,
Aashnee
Photo of Network Administrator

Network Administrator

  • 89 Posts
  • 16 Reply Likes
Thank you.  We are Time and Attendance, and use SAML SSO.
Photo of Network Administrator

Network Administrator

  • 89 Posts
  • 16 Reply Likes
I see status is "Acknowledged" now.  Does this mean the issue is present on your end and your actively seeking resolution?  I would like to tell my users something.
Photo of Aashnee Kamboj

Aashnee Kamboj, Community Moderator

  • 1558 Posts
  • 108 Reply Likes
Yes, it does mean that we acknowledge the issue and we are working on it for a quick resolution.

Regards,
Aashnee
Photo of Network Administrator

Network Administrator

  • 89 Posts
  • 16 Reply Likes
Thank you.
Photo of Aashnee Kamboj

Aashnee Kamboj, Community Moderator

  • 1558 Posts
  • 108 Reply Likes
Hi,

While we are in process of fixing the issue may we please request you follow these temporary steps?

1. Go to Administration and Click on Time Off Type. Create a new time off type and name it as "DO_NOT_USE"

2. Go back to administration and click on Time off settings. Make a note of the current selection for "Time off Type for Holidays". It should ideally be "No Time off allowed on Holidays".

3. Change this option from "No Time off allowed on Holidays" to "DO_NOT_USE"

4. Go back to My Replicon -- Time Off and the issue should be resolved.

We will update this thread as soon as the permanent fix is deployed and the steps that you can follow after the fix to revert the changes.

Thanks,
Aashnee
Photo of Network Administrator

Network Administrator

  • 89 Posts
  • 16 Reply Likes

Thanks, this has fixed the issue for now.  Funny, I KNEW in the back of my mind this issue all was related to the upcoming change in Holiday leave.  Change must have been applied to soon or not tested enough.  Come on Replicon Coders, you can do better than this!


Photo of Network Administrator

Network Administrator

  • 89 Posts
  • 16 Reply Likes
FYI, we were already set to "No Time off allowed on Holidays".  We have never used it because it never worked properly and caused too many headaches.  We just have a "Holiday" as an "Activity" instead, like back in the good-ole self-hosted days. 
Photo of Aashnee Kamboj

Aashnee Kamboj, Community Moderator

  • 1558 Posts
  • 108 Reply Likes
Hi,

We apologize for all the inconvenience caused. We wish to confirm that the permanent fix has been deployed in your instance. May we request you to please perform the following steps:

1. Go to Administration and Click on Time off Settings
2. Choose "No Time off Allowed on Holidays" for the option " Time off type for Holidays"
3. Go back to Administration and click on Time off Type
4. Remove the time off type "DO_NOT_USE" that was created as a part of the temporary fix.

Thanks,
Aashnee
Photo of Network Administrator

Network Administrator

  • 89 Posts
  • 16 Reply Likes

Yes, the permanent fix has now resolved the issue.  Thank you for your quick response and fix deployment. 

Photo of Aashnee Kamboj

Aashnee Kamboj, Community Moderator

  • 1558 Posts
  • 108 Reply Likes
We thank you for all your patience and cooperation.

Happy Posting!

Regards,
Aashnee